Press "Enter" to skip to content

标签: Composer

Composer 切换版本

在开发过程中,有些项目要求 Composer 版本 2 以上,因此需要将已安装的 Composer 进行升级。 首先查看本地 Composer 的版本: composer -v   可以看到,当前 Composer 版本是 1.10.8 。因此需要执行以下命令将 Composer 升级: composer self-update –2 再输入 Composer -v 查看下当前版本: 可以看到已经升级成功了。 如果要切换回之前的版本怎么办呢?其实图 2 已经给出答案了,只要执行以下命…

Leave a Comment

执行 Composer 报错:Allowed memory size of 1610612736 bytes exhausted (tried to allocate 4096 bytes) …

在通过 Composer 创建项目时提示: PHP Fatal error: Allowed memory size of 1610612736 bytes exhausted (tried to allocate 4096 bytes) … 这个问题一般是因为 php.ini 中的 memory_limit 设置过小,命令执行过程中消耗内存超过设定值造成的,可以通过修改 pnp.ini 中的 memory_limit 来解决,找到 php.ini 文件,将 memory_limit 修改为…

Leave a Comment